Navigation:  Using Responsive Time Logger (topic list) > Invoices/Invoicing >

    Invoicing Multiple Clients

Top  Previous  Next

Invoicing More Than One Client At Once

If you have a large number of clients, Time Logger lets you invoice a number of clients at once.

Choose Invoice/Invoice Multiple Clients, and select the clients you want to invoice in the window that appears.  Time Logger will then proceed through the list, printing invoices and/or time reports and/or posting invoices to accounts receivable.  If any errors are encountered, Time Logger will list them when it's done.

TIP: Either use Invoice/Automatic Invoice Filter and then View->Summary for each client to verify you are billing the correct amount to each or use Invoice/Invoice Multiple Clients and in the For Each Client... selection only check "Print Time Report" first to verify that your invoicing amounts will be correct.  Then repeat the process and in the For Each Client... check one of the addition checkboxes.

 

Customizing Invoices using Invoice Multiple Clients

If you need to customize the invoicing for each client, you can do so by creating an Environment file for each client.  The Environment file must be named the exact same as the client's name.

When the system goes to create each Time Report and/or Invoice in the Invoice Multiple Clients feature, it first looks to see if there is an Environment that exists for that Client name.  If it finds one, it uses that Environment to change the settings in Time Logger, such as the Filter and the Invoice Template File.  Thus, you could have a custom Invoice Template for each Client, as well as other custom settings, such as the Filter and Sort Order/Subtotals.

 

Example 1: Invoice for Client ABC Company for Project XYZ System

First, you create a Filter like this for each client where you are invoicing ONE Project:

 

Billed = No and

Billable = Yes and

Client =  ABC Company and

Project = XYZ System end

 

After creating that Filter, you select:

1) Tools->Save Environment...

2) Check ONLY Filter on the "Settings to Save" window and click OK

3) Name it on the Save As window: ABC Company.ev4

 

IMPORTANT: The next time you do Invoice Multiple Clients, or Invoice->Automatic Invoice Filter... it will use the ABC Company.ev4 Environment to set the Filter and you'll be invoicing the same Client and Project.

 

If you need to change the Project or remove it from the Filter, either delete or rename the Environment file ABC Company.ev4 or do this:

1) Tools->Load Environment: ABC Company

2) Filter->Filter Time Records...

3) Change the Filter accordingly.

4) Tools->Save Environment...

5) Leave the Settings to Save as only Filter checked and click OK

6) Save it as the same name and select "Yes" when asked if you want to replace the file.

 

Example 2: Invoice for Client ABC Company for multiple Projects

First, you create a Filter like this for each client where you are invoicing Multiple Projects:

 

Billed = No and

Billable = Yes and

Client =  ABC Company and

Project = XYZ System and

Project = Migration and

Project = Marketing end

 

After creating that Filter, you select:

1) Advanced->SQL Command...

2) Change the SQL Command like this in the red text:

 

From:

select StartDate, StartTime, EndTime, Client, Project, Description, Duration, [Key] from TimeRecords

Where Client= 'ABC Company'

and Billable=-1

and Billed=0

and Project= 'XYZ System'

and Project= 'Migration'

and Project= 'Marketing'

 

To:

select StartDate, StartTime, EndTime, Client, Project, Description, Duration, [Key] from TimeRecords

Where Client= 'ABC Company'

and Billable=-1

and Billed=0

and (Project= 'XYZ System'

or Project= 'Migration'

or Project= 'Marketing')

 

NOTES: Your Select statement may be different.  You may have different numbers of Projects.

IMPORTANT: Once you change your Filter using the Advanced->SQL Command... feature, you cannot view it using the regular Filter window. If you try, you will receive an error to the effect of: "The current filter expression is too complex to be represented in the filter window..."  Select "Yes" to open the Filter in the Advanced->SQL Command... window instead.

 

Then click OK.  At this point you should see Time Records in your main window if you have any that match this Filter.  If you get an error, check your syntax to be sure you replaced the "and" with "or" and added the open "(" and close ")" in the right places.

 

This will tell the system to select all the time records for any one of the three Projects.

 

Then save your Environment:

1) Tools->Save Environment...

2) Check ONLY Filter on the "Settings to Save" window and click OK

3) Name it on the Save As window: ABC Company.ev4

 

IMPORTANT: The next time you do Invoice Multiple Clients, or Invoice->Automatic Invoice Filter... it will use the ABC Company.ev4 Environment to set the Filter and you'll be invoicing the same Client and Project(s).

 

If you need to change the Project(s) or remove it from the Filter, either delete or rename the Environment file ABC Company.ev4 or do this:

1) Tools->Load Environment: ABC Company

2) Advanced->SQL Command...

3) Change the SQL Filter accordingly and click OK.

4) Tools->Save Environment...

5) Leave the Settings to Save as only Filter checked and click OK

6) Save it as the same name and select "Yes" when asked if you want to replace the file.

 

See: Invoice Multiple Clients and Invoice Multiple Clients Window for the details on how to set this up.