Navigation:  Reference by Menu Options > File Menu > Import/From a Text File >

Importing from Excel

Top  Previous  Next

These directions explicitly describe how to Import from Microsoft Excel into Time Logger.

 

Exporting to Excel: To export to Excel, use Export/To a Text File and then open the file created using Excel.

 

Contents Below:

Overview

Example

Steps to export from Excel as CSV & then Import

Steps to export from Excel as Tab Delimited Text & then Import:

What if the Import Fails?

Fixing a Partial Import

Related Topics

 

Note: These directions were created using Microsoft Excel 2003.  If you have a newer or older version, the exact process may differ, but the basic steps should be about the same.

 

Overview: The columns in your spreadsheet must match the Fields to Import you define on the Selection of Fields Window when you import the data.  Using Excel, you must also select File->Save As Comma Separated Values (.csv) or Tab Delimited Text (.txt).  In Time Logger, you must change the field delimiters (User Options Window/Other Tab) to match either the Comma Separated Values (.csv) or Tab Delimited Text (.txt) data in your Excel file.

 

Below are directions for saving the data in Excel as either:

 

1) Comma Separated Values (.csv)

 

-or-

 

2) Tab Delimited Text (.txt)

 

and then importing the file into Time Logger.

 

Example: See Importing from Excel - Example.

 

1) Steps to export from Excel as CSV & then Import:

 

IMPORTANT: THERE MUST BE NO (ZERO) COMMAS IN THE DESCRIPTION OR OTHER FIELDS.  Otherwise, use the 2) Tab Delimited Text (.txt) below.

NOTE: Before importing using this format, be sure that you have done the following in Time Logger:

a) Tools->User Options->Other

b) in "Field Delimiter" put in a comma (,)

c) in "Field Prefix" and "Field Suffix" clear the contents (nothing in each field)

 

IMPORTANT: You must have a data value in every row and cell in Excel, or Time Logger will stop importing when it gets to that row.

 

1) FIRST: Save your Excel file as .xls type.

2) Select only the rows and columns from your main data sheet containing data you want to put into Time Logger. Do not include any column labels.

3) Paste the data rows and columns into a second empty New worksheet.

4) With the New worksheet showing, select File->Save As        

5) For "File name:" give it a name like: "time records from excel Y-M-D", replacing the Y, M and D with the year, month and date.

6) For "Save as type:" select "CSV (Comma delimited) (*.csv)" and click Save

7) Click OK for "To save only the active sheet..."

8) Click "Yes" for "To keep this format..."

9) Close the Excel sheet and select NO to saving the .csv file (you saved it in step 1 above)        

10) Open Time Logger

11) Select File->Import->From Text File

12) Make sure the fields to import are the same and same order (top to bottom order should equal left to right column order in your worksheet)

13) Click OK

14) Select the file you saved in steps 5 to 8 above

 

See: What if the import fails? below.

 

2) Steps to export from Excel as Tab Delimited Text & then Import:

 

IMPORTANT: With this format, there can be commas in the description or other fields. HOWEVER, Excel puts double quotes (") around any field that contains a comma or some other special characters.  Time Logger does not strip these extra double quotes.  You must edit the .txt file saved by Excel using Notepad and remove all of the double quotes with the Search & Replace option.

 

NOTE: Before importing using this format, be sure that you have done the following in Time Logger:

a) Tools->User Options->Other

b) in "Field Delimiter" put in \t  (that's a backslash \ and a lower case t with no space between each)

c) in "Field Prefix" and "Field Suffix" clear the contents (nothing in each field)

 

1) FIRST: Save your Excel file as .xls type.

2) Select only the rows and columns from your main data sheet containing data you want to put into Time Logger. Do not include any column labels.

3) Paste the data rows and columns into a second empty New worksheet.

4) With the New worksheet showing, select File->Save As        

5) For "File name:" give it a name like: "time records from excel Y-M-D", replacing the Y, M and D with the year, month and date.

6) For "Save as type:" select "Text (Tab delimited) (*.txt)" and click Save

7) Click OK for "To save only the active sheet..."

8) Click "Yes" for "To keep this format..."

9) Close the Excel sheet and select NO to saving the .txt file (you saved it in step 1 above)        

10) Open Time Logger

11) Select File->Import->From Text File

12) Make sure the fields to import are the same and same order (top to bottom order should equal left to right column order in your worksheet)

13) Click OK

14) Change the File type: field to .txt

15) Select the file you saved in steps 5 to 8 above

 

What if the Import Fails?

 

1) If you see the message:

 

File_Import_File_Locked_Error_Message

 

Then chances are that you did not close Excel in step 9 above.  Close Excel and try again.

 

2) If it fails on row 1, then no data was imported.  If it fails after row 1, then only some of the rows were imported and you have partial import.  See Fixing a Partial Import below.

 

3) Check to see if you saved your column labels.  If so, you can simply remove that row from the .csv or .txt file and try the import again.

 

4) Check to verify that the fields (columns) that you are importing (Selection of Fields Window) are the exact same as in your Excel worksheet that you exported.  You may need to change the fields accordingly and try again.

 

5) Check to verify that data values are present in every field (cell or column).

 

6) Check to verify that the data values are correct.  For example, 1) Yes or No for the field Billable (instead of a number); 2) A decimal number for the Rate (instead of letters or other special characters).

 

7) Check to verify that the Field Delimiter, Field Prefix and Field Suffix are correct: User Options Window/Other Tab

 

Fixing a Partial Import

 

If only part of your data was imported, simply use Notepad to delete the rows in the file up to the line number (row) where the failure was reported.  Then, fix your data using the steps above and import the rest of the data.

 

More:

Import/From a Text File

Selection of Fields Window

Importing from Excel - Example