Navigation:  Using Responsive Time Logger (topic list) >

    Adding a Time Record

Top  Previous  Next

There are two ways to use Time Logger to record your time.  The first is to add a time record to the database after-the-fact, and the second is to track your time automatically with the stopwatch.  This topic describes the first method.

When adding a record after-the-fact, you're essentially telling Time Logger something like this:

"Today I worked for AR Software from 8:53 AM until 10:06 on the EasyCalc project."

To add a time record, just choose Records/New Time Record or press the F4 key.  This will bring up the Time Record Editor window that will allow you to describe the record.  Here's what it looks like:

EditDialog

Let's look at some of the controls in this window.

The controls at the top left let you describe when you did the work.  You can choose a start and end date and time or you can simply enter a duration.  The little calendar and clock buttons let you select the date or time with the mouse.

The controls in the center let you describe what you did.  Person, Client, Project, etc. are called "descriptors" because they describe the time record.  For each of these descriptors, you can choose from a list of available descriptors by clicking on the down arrow at the right of the control.

The three buttons at the right of each descriptor control let you add, edit, or delete the descriptor respectively.  Click the button with the green plus sign to add a new descriptor.  To edit the currently selected descriptor, click the button with the picture of a pencil on it.  Clicking the button that displays a red minus sign will delete the currently selected descriptor.

You may also enter a narrative description of what you did in the Description edit box.

When you've entered your information about what you did and when you did it, click the OK button.  As soon as you do that, Time Logger will add the new record to the database and highlight (or "select") that record in the time record list.  If you want to make any changes, either double-click on the time record or right click on the selected record and choose "Edit Selected Record" in the menu that appears.

If you want to add a bunch of records in a row, click OK & Repeat instead of OK.  This will add the record, then display the window again for the next record.

There are a number of buttons and controls that we haven't discussed here – there are even buttons and controls that don't appear unless you click the "More >>" button!  For more on the Edit Record Window, see Time Record Editor Window.

 

IMPORTANT: After you click OK to add the time record, the time record will be added to the time records list that appears in the main window. However, you might not be able to immediately see it if:

 

Your Filter is excluding it from the list.

To fix this: either change the Filter by pressing F5 or Filter->Filter Time Records or Toolbar-Filter-Button and modifying it accordingly,

or press F6 or Filter->Clear Filter or Toolbar_Clear_Filter_Active to clear the filter.

 

Your Sort Order changes where it is in the list.

       To fix this: press F7 or Tools->Sort Order/Subtotals or Toolbar-Sort-Order-Button and either click the Use Defaults button or change the sort order.

 

Your time records list is longer than your screen size.

 

       To fix this simply scroll up or down the list.

More:

Deleting one or more Time Records

Time Record Editor Window